Korg Electribe ER-1 completely dead

Ask and discuss about how to work with electribes. Share your discoveries and ideas.

Moderator: Aciphecs

Korg Electribe ER-1 completely dead

Postby alifhughes on Sun Aug 20, 2017 2:00 am

Hey all,

I'm new to the forum as I would like to try find out if the problem i've encountered with my Korg Electribe ER-1 isn't terminal.

This morning when to turn on my ER-1 as per usual with my headphones in and I heard a click sound and suddenly it is dead. There are no lights appearing on the machine, nothing in the display, no sound, completely dead.

I have checked the power supply with a multimeter and it is working fine and reading correctly, meaning it is the unit itself.

I have read about the fuse issues that come with the EMX-1, etc. so I guess this could apply to the ER-1 as well? Does anyone know this for certain?

Has anyone else had a similar expierence or could tell me if this is terminal?

Any help is greatly appreciated!

Thanks
alifhughes
Electribe Newbie
 
Posts: 1
Joined: Sun Aug 20, 2017 1:46 am

Re: Korg Electribe ER-1 completely dead

Postby StellarJay[aka Ruso] on Sun Dec 03, 2017 7:37 pm

On the EMX/ESX machines, there's a fuse in the circuitry of the main board near the power area. I don't have these machines any more (it's been a long time since I owned one) but I remember bypassing the fuse on my EMX after this happened.

Good luck!

BTW, when you find the fuse, you can test by manually bypassing it with some tweezers with the machine open (VERY CAREFULLY) to see if it turns on... and then either desolder and solder a new one... or bypass by soldering a small wire between the two leads.
User avatar
StellarJay[aka Ruso]
Site Admin
 
Posts: 1834
Joined: Wed May 14, 2008 7:43 pm
Location: Seattle, WA


Return to Technical Talk

Who is online

Users browsing this forum: No registered users and 4 guests

cron