[ESX 1]Ribbon contacts outworn

Ask and discuss about how to work with electribes. Share your discoveries and ideas.

Moderator: Aciphecs

[ESX 1]Ribbon contacts outworn

Postby Paul9 on Tue Aug 13, 2019 7:36 am

Hello.
First to say: English isnt my mother tongue, but i hope, i can make you understand what my problem is :)
I bought an ESX from Ebay which was not working at all (scammer alert :( ), so i fixed a lot of stuff and since yesterday, the Ribbon controller contacts are outworn.
Since i cant find any ressource in Germany or nearby countries which can provide a new controller, i wanted to fix it myself.
Can anybody give me a tip how to solve the problem the best way? I tried to connect copper cables on top of the old contacts, but this didnt work out, somehow.
Should i just disconnect the white thingy? It has 5 connections, the cable only 3 lines. Whoch connection is for what?
I hope you can help me, since i spent a lot of money and time for the Electribe and already was able to use it. I just wanted to change the last thing, the arp slider and now that happened :roll:
Attachments
20190813_170212.jpg
20190813_170212.jpg (3.37 MiB) Viewed 324 times
Paul9
Electribe Newbie
 
Posts: 2
Joined: Tue Aug 13, 2019 7:24 am

Re: [ESX 1]Ribbon contacts outworn

Postby Paul9 on Wed Aug 14, 2019 4:09 am

Solved. The solution was pretty easy. Theres something called silver lacquer (google translator :D) and its even less destructable than the copper print on thw flex cable.
Paul9
Electribe Newbie
 
Posts: 2
Joined: Tue Aug 13, 2019 7:24 am


Return to Technical Talk

Who is online

Users browsing this forum: No registered users and 2 guests

cron