Page 1 of 1

My first Electribe videos

PostPosted: Tue Feb 21, 2012 11:57 am
by tomamusic
Hi Guys, my first post here. I have had an ESX for 6 months now and have just put together my firstyoutube videos. Any comments/feedback would be much appreciated:

http://www.youtube.com/watch?v=28P-dzJ2T1g

and

http://www.youtube.com/watch?v=esbiLVGm ... re=channel

Im also selling the Electribe here, so that i can upgrade to one with an SD card (my one has smart media), so anyone in the UK please get in touch :)

Cheers

T

Re: My first Electribe videos

PostPosted: Tue Feb 21, 2012 12:35 pm
by beirney82
That was effin cool! The first one reminds me of Flying Lotus rockin

Re: My first Electribe videos

PostPosted: Wed Feb 22, 2012 2:30 am
by tomamusic
Thanks Man, i Listen to Fly Lo a lot, but i dont feel the 'tribes lend themselves to that sort of music as well as something like an MPC. The swing on the ESX is pretty nice tho, so i figured it was worth having a go with!

I ned to get away from the stock sounds that came with my ESX tho, building your own sample bank is hard tho...

Re: My first Electribe videos

PostPosted: Fri Mar 02, 2012 9:10 am
by beirney82
Yeah I konw what you mean. There are some good sites for downloading free WAV samples though. I'm slowly gathering a selection together this way, along with straight sampling from music from my collection and youtube.

Re: My first Electribe videos

PostPosted: Fri Mar 02, 2012 9:18 am
by adamitron
i really dig the little droid you have on your tribe. nice sounds, and welcome to the forum.

Re: My first Electribe videos

PostPosted: Sun Mar 11, 2012 3:19 pm
by tomamusic
Haha, yeah, got to love a bit of LEGO R2 D2 :D

I have recently picked up some really nice wavs from gold baby and a few other places, so that will hopefully sort out some of my sample woes. Im having a stress with Open Electribe Editor which appears to only load about 1 in 10 samples, and completely fails to register the others, i will post another thread a botu this as its really irritating!

Also picked up two Kaoss Pad 3's which are great coupled with the ESX!

(finally a chance to use the 4 outputs!)

toma